Требования

PECL/oauth требует PHP 5.1 или новее, расширение hash и расширение pcre.

Дополнительно, PECL/oauth может понадобиться libcurl, если оно было указано во время компиляции. Если сконфигурировано с libcurl, то оно должно быть собрано с поддержкой HTTPS.