Особенности признаные устаревшими в PHP 5.5.x

Расширение ext/mysql признано устаревшим

Оригинальное расширение MySQL признано устаревшим и будет выдавать ошибку уровня E_DEPRECATED при установлении соединения с базой данных. Вместо него используйте расширения MySQLi или PDO_MySQL.

preg_replace(), модификатор /e

Использование в функции preg_replace() модификатора /e объявлено устаревшим. В качестве альтернативы используйте функцию preg_replace_callback().

intl

IntlDateFormatter::setTimeZoneID() и datefmt_set_timezone_id() признаны устаревшими. Используйте метод IntlDateFormatter::setTimeZone() и функцию datefmt_set_timezone(), соответственно.

mcrypt

Следующие функции признаны устаревшими: